import re
regex = re.compile(r"(?<=href=\")(.*?\.(.*?))\\")
test_str = "some random text <a href=\"http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\\\">Link1</a><a href=\"http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\\\">Link2</a>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")