use strict;
my $str = 'some random text <a href="http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\\">Link1</a><a href="http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\\">Link2</a>';
my $regex = qr/(?<=href=")(.*?\.(.*?))\\/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}