#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\-+\*=]+\s*[\-+\*=]{1,2}\s*('[^']+')\s*\&\&"
Local $sString = "mydate == 'one day ago' && mydate > '2014-05-16 16:00:00'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")