using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\-+\*=]+\s*[\-+\*=]{1,2}\s*('[^']+')\s*\&\&";
string input = @"mydate == 'one day ago' && mydate > '2014-05-16 16:00:00'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}