const regex = /[^\-+\*=]+\s*[\-+\*=]{1,2}\s*('[^']+')\s*\&\&/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\-+\\*=]+\\s*[\\-+\\*=]{1,2}\\s*(\'[^\']+\')\\s*\\&\\&', '')
const str = `mydate == 'one day ago' && mydate > '2014-05-16 16:00:00'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}