package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\-+\*=]+\s*[\-+\*=]{1,2}\s*('[^']+')\s*\&\&`)
var str = `mydate == 'one day ago' && mydate > '2014-05-16 16:00:00'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}