#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=(http:\/\/.*turkcell|vodafone|avea\.)(?!com\.tr))"
Local $sString = "sadfwesfs" & @CRLF & _
"http://vodafone.avea.turkcell.cm" & @CRLF & _
"http://tukcell.com.tr" & @CRLF & _
"http://www.turkcell.com.tr" & @CRLF & _
"sadsd http://avea.com.tr sads" & @CRLF & _
"dsadsa http://avea.com.tr sds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")