import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(http:\\/\\/.*turkcell|vodafone|avea\\.)(?!com\\.tr))";
final String string = "sadfwesfs\n"
+ "http://vodafone.avea.turkcell.cm\n"
+ "http://tukcell.com.tr\n"
+ "http://www.turkcell.com.tr\n"
+ "sadsd http://avea.com.tr sads\n"
+ "dsadsa http://avea.com.tr sds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}