using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(http:\/\/.*turkcell|vodafone|avea\.)(?!com\.tr))";
string input = @"sadfwesfs
http://vodafone.avea.turkcell.cm
http://tukcell.com.tr
http://www.turkcell.com.tr
sadsd http://avea.com.tr sads
dsadsa http://avea.com.tr sds";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}