re = /(?=(http:\/\/.*turkcell|vodafone|avea\.)(?!com\.tr))/mi
str = 'sadfwesfs
http://vodafone.avea.turkcell.cm
http://tukcell.com.tr
http://www.turkcell.com.tr
sadsd http://avea.com.tr sads
dsadsa http://avea.com.tr sds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end