import Foundation
let pattern = #"(?=(http:\/\/.*turkcell|vodafone|avea\.)(?!com\.tr))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
sadfwesfs
http://vodafone.avea.turkcell.cm
http://tukcell.com.tr
http://www.turkcell.com.tr
sadsd http://avea.com.tr sads
dsadsa http://avea.com.tr sds
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)