const regex = /(?=(http:\/\/.*turkcell|vodafone|avea\.)(?!com\.tr))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(http:\\\/\\\/.*turkcell|vodafone|avea\\.)(?!com\\.tr))', 'gmi')
const str = `sadfwesfs
http://vodafone.avea.turkcell.cm
http://tukcell.com.tr
http://www.turkcell.com.tr
sadsd http://avea.com.tr sads
dsadsa http://avea.com.tr sds`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}