#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z]+[A-Z ]*[A-Z])"
Local $sString = "" & @CRLF & _
"0" & @CRLF & _
"down vote" & @CRLF & _
"favorite" & @CRLF & _
"I got to extract string like "THE NEED OF FOLLOWING A RELIGION " from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like "THE NEED OF FOLLOWING A RELIGION" but not able to do so,, any help."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")