const regex = /([A-Z]+[A-Z ]*[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]+[A-Z ]*[A-Z])', 'g')
const str = `
0
down vote
favorite
I got to extract string like "THE NEED OF FOLLOWING A RELIGION " from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like "THE NEED OF FOLLOWING A RELIGION" but not able to do so,, any help.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}