# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Z]+[A-Z ]*[A-Z])"
test_str = ("\n"
"0\n"
"down vote\n"
"favorite\n"
"I got to extract string like \"THE NEED OF FOLLOWING A RELIGION \" from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like \"THE NEED OF FOLLOWING A RELIGION\" but not able to do so,, any help.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.