import Foundation
let pattern = #"([A-Z]+[A-Z ]*[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0
down vote
favorite
I got to extract string like "THE NEED OF FOLLOWING A RELIGION " from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like "THE NEED OF FOLLOWING A RELIGION" but not able to do so,, any help.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)