re = /([A-Z]+[A-Z ]*[A-Z])/
str = '
0
down vote
favorite
I got to extract string like "THE NEED OF FOLLOWING A RELIGION " from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like "THE NEED OF FOLLOWING A RELIGION" but not able to do so,, any help.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end