// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]+[A-Z ]*[A-Z])").unwrap();
let string = "
0
down vote
favorite
I got to extract string like \"THE NEED OF FOLLOWING A RELIGION \" from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like \"THE NEED OF FOLLOWING A RELIGION\" but not able to do so,, any help.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}