# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\s+:\s+(.*)/$2 : $1/g;t' <<< "some english sentence : une phrase en francais
another one : une autre"