re = /(.*)\s+:\s+(.*)/
str = 'some english sentence : une phrase en francais
another one : une autre'
subst = '$2 : $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result