using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\s+:\s+(.*)";
string substitution = @"$2 : $1";
string input = @"some english sentence : une phrase en francais
another one : une autre";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}