#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)\s+:\s+(.*)"
Local $sString = "some english sentence : une phrase en francais" & @CRLF & _
"another one : une autre"
Local $sSubst = "$2 : $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)