use strict;
my $str = 'some english sentence : une phrase en francais
another one : une autre';
my $regex = qr/(.*)\s+:\s+(.*)/p;
my $subst = '$2 : $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";