package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)\s+:\s+(.*)`)
var str = `some english sentence : une phrase en francais
another one : une autre`
var substitution = "$2 : $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}