#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)[\d][\d.,]*(?=[\s]?[(].*?[)])|" & @CRLF & _
"[\d][\d.,]*(?=\s?$)" & @CRLF & _
"#(?<=.[.\s])[\d.,]+(?=(\s?[(].*?[)])|\s?) ini juga bisa"
Local $sString = "Rp.1.000.005,52 (35 %)" & @CRLF & _
"Rp. 1.000.005,52(35 %)" & @CRLF & _
"Rp.1.000.005,52(35 %)" & @CRLF & _
"Rp. 1.000.005,52 (35 %)" & @CRLF & _
"asd. 1.01203102,00 (31 %)" & @CRLF & _
"asd. 1.012.031.702,00" & @CRLF & _
"asd. 1.100.001,00 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")