using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d][\d.,]*(?=[\s]?[(].*?[)])|
[\d][\d.,]*(?=\s?$)
#(?<=.[.\s])[\d.,]+(?=(\s?[(].*?[)])|\s?) ini juga bisa";
string input = @"Rp.1.000.005,52 (35 %)
Rp. 1.000.005,52(35 %)
Rp.1.000.005,52(35 %)
Rp. 1.000.005,52 (35 %)
asd. 1.01203102,00 (31 %)
asd. 1.012.031.702,00
asd. 1.100.001,00 ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}