import Foundation
let pattern = ##"""
[\d][\d.,]*(?=[\s]?[(].*?[)])|
[\d][\d.,]*(?=\s?$)
#(?<=.[.\s])[\d.,]+(?=(\s?[(].*?[)])|\s?) ini juga bisa
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Rp.1.000.005,52 (35 %)
Rp. 1.000.005,52(35 %)
Rp.1.000.005,52(35 %)
Rp. 1.000.005,52 (35 %)
asd. 1.01203102,00 (31 %)
asd. 1.012.031.702,00
asd. 1.100.001,00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)