# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
[\d][\d.,]*(?=[\s]?[(].*?[)])|
[\d][\d.,]*(?=\s?$)
#(?<=.[.\s])[\d.,]+(?=(\s?[(].*?[)])|\s?) ini juga bisa
"""
test_str = ("Rp.1.000.005,52 (35 %)\n"
"Rp. 1.000.005,52(35 %)\n"
"Rp.1.000.005,52(35 %)\n"
"Rp. 1.000.005,52 (35 %)\n"
"asd. 1.01203102,00 (31 %)\n"
"asd. 1.012.031.702,00\n"
"asd. 1.100.001,00 ")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.