const regex = new RegExp('[\\d][\\d.,]*(?=[\\s]?[(].*?[)])|
[\\d][\\d.,]*(?=\\s?$)
#(?<=.[.\\s])[\\d.,]+(?=(\\s?[(].*?[)])|\\s?) ini juga bisa', 'gm')
const str = `Rp.1.000.005,52 (35 %)
Rp. 1.000.005,52(35 %)
Rp.1.000.005,52(35 %)
Rp. 1.000.005,52 (35 %)
asd. 1.01203102,00 (31 %)
asd. 1.012.031.702,00
asd. 1.100.001,00 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}