use strict;
my $str = 'Rp.1.000.005,52 (35 %)
Rp. 1.000.005,52(35 %)
Rp.1.000.005,52(35 %)
Rp. 1.000.005,52 (35 %)
asd. 1.01203102,00 (31 %)
asd. 1.012.031.702,00
asd. 1.100.001,00 ';
my $regex = qr/[\d][\d.,]*(?=[\s]?[(].*?[)])|
[\d][\d.,]*(?=\s?$)
#(?<=.[.\s])[\d.,]+(?=(\s?[(].*?[)])|\s?) ini juga bisa/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}