$re = '/[\d][\d.,]*(?=[\s]?[(].*?[)])|
[\d][\d.,]*(?=\s?$)
#(?<=.[.\s])[\d.,]+(?=(\s?[(].*?[)])|\s?) ini juga bisa/mx';
$str = 'Rp.1.000.005,52 (35 %)
Rp. 1.000.005,52(35 %)
Rp.1.000.005,52(35 %)
Rp. 1.000.005,52 (35 %)
asd. 1.01203102,00 (31 %)
asd. 1.012.031.702,00
asd. 1.100.001,00 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);