using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d\w\\]+)\s*([\d\w]+)\s*(?:([\d\w]+)|,)";
string input = @"@a\sdfasdf sdsdfasdf
@as\dfasdf sdsdfasdf asdfasdf
@asdfa\sdf sdsdfasdf asdfasdf, asdasd
@as\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}