re = /([\d\w\\]+)\s*([\d\w]+)\s*(?:([\d\w]+)|,)/
str = '@a\\sdfasdf sdsdfasdf
@as\\dfasdf sdsdfasdf asdfasdf
@asdfa\\sdf sdsdfasdf asdfasdf, asdasd
@as\\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end