$re = '/([\d\w\\\\]+)\s*([\d\w]+)\s*(?:([\d\w]+)|,)/';
$str = '@a\\sdfasdf sdsdfasdf
@as\\dfasdf sdsdfasdf asdfasdf
@asdfa\\sdf sdsdfasdf asdfasdf, asdasd
@as\\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);