import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d\\w\\\\]+)\\s*([\\d\\w]+)\\s*(?:([\\d\\w]+)|,)";
final String string = "@a\\sdfasdf sdsdfasdf \n"
+ "@as\\dfasdf sdsdfasdf asdfasdf\n"
+ "@asdfa\\sdf sdsdfasdf asdfasdf, asdasd\n"
+ "@as\\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}