#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\d\/-]+"
Local $sString = "Estou tentando montar uma expressão regular e não estou conseguindo." & @CRLF & _
"" & @CRLF & _
"Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?" & @CRLF & _
"" & @CRLF & _
"Mas opde ser essa possibilidade 2345/-tbm?" & @CRLF & _
"" & @CRLF & _
"Ou /-234opde ser essa possibilidade 2345/-tbm?" & @CRLF & _
"" & @CRLF & _
"Se vc apagar o modificador g verá uma diferença." & @CRLF & _
"" & @CRLF & _
"1234/-" & @CRLF & _
"" & @CRLF & _
"-/1234y" & @CRLF & _
"" & @CRLF & _
"/-k2565" & @CRLF & _
"" & @CRLF & _
"/345663-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")