# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\d\/-]+"
test_str = ("Estou tentando montar uma expressão regular e não estou conseguindo.\n\n"
"Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?\n\n"
"Mas opde ser essa possibilidade 2345/-tbm?\n\n"
"Ou /-234opde ser essa possibilidade 2345/-tbm?\n\n"
"Se vc apagar o modificador g verá uma diferença.\n\n"
"1234/-\n\n"
"-/1234y\n\n"
"/-k2565\n\n"
"/345663-")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.