re = /[\d\/-]+/
str = 'Estou tentando montar uma expressão regular e não estou conseguindo.
Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?
Mas opde ser essa possibilidade 2345/-tbm?
Ou /-234opde ser essa possibilidade 2345/-tbm?
Se vc apagar o modificador g verá uma diferença.
1234/-
-/1234y
/-k2565
/345663-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end