use strict;
my $str = 'Estou tentando montar uma expressão regular e não estou conseguindo.
Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?
Mas opde ser essa possibilidade 2345/-tbm?
Ou /-234opde ser essa possibilidade 2345/-tbm?
Se vc apagar o modificador g verá uma diferença.
1234/-
-/1234y
/-k2565
/345663-';
my $regex = qr/[\d\/-]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}