package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d\/-]+`)
var str = `Estou tentando montar uma expressão regular e não estou conseguindo.
Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?
Mas opde ser essa possibilidade 2345/-tbm?
Ou /-234opde ser essa possibilidade 2345/-tbm?
Se vc apagar o modificador g verá uma diferença.
1234/-
-/1234y
/-k2565
/345663-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}