import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d\\/-]+";
final String string = "Estou tentando montar uma expressão regular e não estou conseguindo.\n\n"
+ "Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?\n\n"
+ "Mas opde ser essa possibilidade 2345/-tbm?\n\n"
+ "Ou /-234opde ser essa possibilidade 2345/-tbm?\n\n"
+ "Se vc apagar o modificador g verá uma diferença.\n\n"
+ "1234/-\n\n"
+ "-/1234y\n\n"
+ "/-k2565\n\n"
+ "/345663-";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}