# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}/\1\2\3/g;t' <<< "
Google
- negative$4.99
Jun 21Automatic Payment
Google
- negative$4.99
Jun 21Automatic Payment
Loading transaction details for
Google
- negative$4.99
Jun 21Automatic Payment
"