#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}"
Local $sString = "" & @CRLF & _
"Google" & @CRLF & _
"- negative$4.99" & @CRLF & _
"Jun 21Automatic Payment" & @CRLF & _
"Google" & @CRLF & _
"- negative$4.99" & @CRLF & _
"Jun 21Automatic Payment" & @CRLF & _
"Loading transaction details for" & @CRLF & _
"Google" & @CRLF & _
"- negative$4.99" & @CRLF & _
"Jun 21Automatic Payment" & @CRLF & _
""
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)