use strict;
my $str = '
Google
- negative$4.99
Jun 21Automatic Payment
Google
- negative$4.99
Jun 21Automatic Payment
Loading transaction details for
Google
- negative$4.99
Jun 21Automatic Payment
';
my $regex = qr/([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}/p;
my $subst = '\\1\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";