re = /([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}/
str = '
Google
- negative$4.99
Jun 21Automatic Payment
Google
- negative$4.99
Jun 21Automatic Payment
Loading transaction details for
Google
- negative$4.99
Jun 21Automatic Payment
'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result