const regex = /([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\v\\t]+)\\s*([^\\v\\t]+)\\s*([^\\v\\t]+)([\\v\\t]+|Loading transaction details for|[\\v\\t]+\\1){0,3}', 'g')
const str = `
Google
- negative\$4.99
Jun 21Automatic Payment
Google
- negative\$4.99
Jun 21Automatic Payment
Loading transaction details for
Google
- negative\$4.99
Jun 21Automatic Payment
`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);