import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\v\\t]+)\\s*([^\\v\\t]+)\\s*([^\\v\\t]+)([\\v\\t]+|Loading transaction details for|[\\v\\t]+\\1){0,3}";
final String string = "\n"
+ "Google\n"
+ "- negative$4.99\n"
+ "Jun 21Automatic Payment\n"
+ "Google\n"
+ "- negative$4.99\n"
+ "Jun 21Automatic Payment\n"
+ "Loading transaction details for\n"
+ "Google\n"
+ "- negative$4.99\n"
+ "Jun 21Automatic Payment\n";
final String subst = "\\1\\2\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}