#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)"(wert|wert2)"\s*:\s*{\s*"WERTNAME"\s*:\s*"?([^,"]+)"
Local $sString = ""wert":{"WERTNAME":XXXXXXX," & @CRLF & _
""wert2":{"WERTNAME":XXXXXX," & @CRLF & _
""wert2":{"WERTNAME":"XXXXXX"," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")