re = /"(wert|wert2)"\s*:\s*{\s*"WERTNAME"\s*:\s*"?([^,"]+)/mi
str = '"wert":{"WERTNAME":XXXXXXX,
"wert2":{"WERTNAME":XXXXXX,
"wert2":{"WERTNAME":"XXXXXX",
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end