$re = '/"(wert|wert2)"\s*:\s*{\s*"WERTNAME"\s*:\s*"?([^,"]+)/mi';
$str = '"wert":{"WERTNAME":XXXXXXX,
"wert2":{"WERTNAME":XXXXXX,
"wert2":{"WERTNAME":"XXXXXX",
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);